martes, 4 de septiembre de 2012

promediar viento en excel

Supongamos que tenemos mediciones de la dirección del viento en Excel minuto a minuto (de 0 a 360) y queremos obtener el promedio horario. Aplicar el promedio aritmético es incorrecto, puesto que si el viento oscila entre 350 y 10 grados (dirección Norte), lo mas seguro es que el promedio sea un valor cercano a 180 (dirección Sur).
Para ésto se debe hacer (suponiendo que nuestros valores de viento están desde la fila A1 a la A60):

=REDONDEAR(RESIDUO(ATAN2(REDONDEAR(PROMEDIO(COS(A1:A60*PI()/180));3);REDONDEAR(PROMEDIO(SENO(A1:A60*PI()/180));3))*180/PI()+360;360);1)

Y se debe ingresar la fórmula presionando CTRL+SHIFT+ENTER, para que el cálculo se efectúe de manera matricial.